User Login    
 + Register
  • Main navigation
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Who's Online
14 user(s) are online (9 user(s) are browsing Forum)

Members: 0
Guests: 14

more...
Donation
If you like NovaSmart modules & hack, please donate some money. We will use the money to pay out programmer for "extra hour " job so your favorite modules/hack will get updated.


for



* Credit card also accepted through paypal

Total Donation so far: USD$45.00
Alexa Ranking

Browsing this Thread:   1 Anonymous Users





Bug with publish date
Not too shy to talk
Joined:
2008/3/12 14:56
Group:
Registered Users
Posts: 35
Level : 4; EXP : 68
HP : 0 / 92
MP : 11 / 1804
Offline

I wrote an new article at 14.33 hours. Publish date NOT checked (Normal wen writing a new article)

Published it and everything normal.


Went back to modify it, then the Publish date IS checked. No problem but the publish time was set to 14.40 hours.

Published the article and it was gone for about  six minutes (Normal because of publish time)



Not a big problem for me but might be for the authors when writing and editing.

Perhaps set the publish time 10 minutes earlier and check the publish date also when writing a new article?


 


 


Posted on: 2008/8/10 18:03
Transfer the post to other applications Transfer


Re: Bug with publish date
Just can't stay away
Joined:
2008/3/12 17:44
Group:
Webmasters
Posts: 76
Level : 7; EXP : 65
HP : 0 / 166
MP : 25 / 3261
Offline
I can reproduce the bug that you reported and try to explore what the best way to fix it however, the fix is not straight forward.

XOOPS is the one who ceiling the date-time value and cause the problem. If I want to fix it in AMS, I need to backdated publish time 10 minutes earlier (like you suggest), but it will introduce new bugs; when we publish multiple time, publish time will keep pull 10 minutes earlier and that will cause incorrect publish time.

So, I need to put more decision (if a then b...bla bla bla), and it may introduce other bugs or sacrifice some performance if I not coding carefully.

The conclusion:
It can be fixed but after i need to do more validation. Will be available in public AMS 2.50 Beta 1 (in nex few days), and not overnight build.

Posted on: 2008/8/11 23:15
Transfer the post to other applications Transfer


Re: Bug with publish date
Not too shy to talk
Joined:
2008/3/12 14:56
Group:
Registered Users
Posts: 35
Level : 4; EXP : 68
HP : 0 / 92
MP : 11 / 1804
Offline
Must the publish time be selected on edit?

Everything was working fine, just the republish of an expired article was a problem (i thought so?).

I think you just need to check (on republish) the archive date.
If publish date is > then archive date then remove archive date

Posted on: 2008/8/12 1:00

Edited by NovaSmart on 2008/8/18 12:41:30
Transfer the post to other applications Transfer


Re: Bug with publish date
Just can't stay away
Joined:
2008/3/12 17:44
Group:
Webmasters
Posts: 76
Level : 7; EXP : 65
HP : 0 / 166
MP : 25 / 3261
Offline
Bug fixed in AMS 2.50 Beta 2

Posted on: 2008/8/28 1:46
Transfer the post to other applications Transfer






You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.

[Advanced Search]